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Why SharePoint 
 Version control 

– Each library can be set to keep prior versions of a file. Files with the same name will 
overwrite each other to ensure the most recent one is available.  

– By eliminating the practice of emailing files, you can be sure that the single version on 
SharePoint is the most current version without guessing.  

– Eliminate rework and save time.  
 Accountability 

– Each save records who the file was last modified by.  
– Comments can be used to alert coworkers of changes and pertinent information.  

 Security 
– Security groups can be created to meet group needs. 
– Each document library, calendar, and discussion group can be made accessible 

accessible only to the members in the allowed groups, at the allowed level. 
– Permissions can be customized down to the file level, if needed.  

 Centralized communication 
– Using discussion boards instead of email for information that needs to be dispersed to 

an entire team ensures that it doesn’t get lost in an inbox.  
– Information remains easily accessible to all team members.  
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Browser Requirements 
 Internet Explorer (IE) 

– IE is the only browser fully 
compatible with SharePoint. 

– Firefox and Chrome are 
incompatible. While they will 
allow you to view some areas 
seamlessly, they cannot 
complete all the functions 
available or utilized by 
SharePoint sites.  
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Terminology 
 Alert 

– A notification to users  that there are changes to existing information or new information  
in a specified location. Alerts can be set on individual files, lists, libraries, and pages.  

 Discussion board 
– A central location t share information under multiple topics.  

 Document library  
– A list where documents and folders are stored. The document library settings control 

versioning settings, workflow settings, and information policies. 
 List 

– A list is a collection of information items displayed in an area or on a site. List types 
include: Announcements, Links, Contacts, Events, Tasks, and Issues. 

 Page 
– A user-created area on a SharePoint site for displaying content. 

 Public-facing site 
– A SharePoint site that is accessible by all LM and LMS employees.  

 Security group 
– A collection of defined users that can be granted permission to documents, libraries, 

lists, and sites as a group.  
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Terminology 
 Site 

– A complete SharePoint site stored in a named portion of the top-level site. 
 Subsite 

– A named subdirectory of the top-level site that is a complete site. Each subsite can 
have independent administration, authoring, and browsing permissions from the top-
level sites and other subsites. 

 Team site 
– A SharePoint site accessible only by the team members defined in security or  

domain groups.  
 View 

– A named collection of settings for querying and displaying items or documents in a 
SharePoint list or library. There are two types of views: Personal, which can be used 
only by the user who creates them; and Public, which can be used by all users who 
have access to the site.  

 Web part 
– Customizable page element that can be added to SharePoint pages. 

 Workflow 
– The automation of processes, where documents and tasks are passed automatically 

from one user to another for action, according to a set sequence. 
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LISTS AND LIBRARIES 



Lists and Libraries 

Lists 
 Made up of line items 
 Can hold attachments 
 Created by adding 

information lines 

Libraries 
 Made up of files including 

documents, spreadsheets, 
slide presentations, 
images, and more 
 Created by uploading or 

creating a file 
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Creating a List or Library 
To create a new list or library: 
 
 Go to All Site Content, 

located on the bottom of the 
left-hand navigation menu on 
any page. 

 Click Create at the top of the 
page. 
 

Back to 
Contents 



Creating a List or Library 
 Select the thing you want to create. Use the filters on the left to display fewer 

options.  
 Give the list or library a name and click Create.  
 More Options will give you the choice to add a link to the left-hand navigation menu. 
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Adding Columns 
You can add existing site columns or create custom columns for any list 
or library.  
 
To add columns, navigate to the list or library and go to List (Library 
Tools > List (Library) > List (Library) Settings.  
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Adding Columns 
Under Columns select Add from existing site columns or Create 
column based on your needs.  
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Adding Columns 
If choosing to 
create a column, 
select the options 
for the column.  
After making the 
column 
selections, click 
OK. 
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Questions 
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Creating Views 
Multiple views can be created for any list or library by going to List 
(Library) Tools > List (Library) > Create View.  
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Creating Views 
Select one of the formats to begin from scratch or select an existing 
view to modify it to create a new one.  
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Creating Views 
Name the view, select the audience (public or personal), the columns 
to display, and sorting and grouping options. 
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Questions 
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UPLOADING FILES 



Uploading Files 
To upload a new file, navigate to your desired library and click Add 
document in the lower left of the library.   

Back to 
Contents 

You can also go to the ribbon and click Upload document.  



Uploading Files 
 Click Browse to locate a single file 

for upload.  
 Select the folder, if necessary, by 

clicking Choose Folder…(this will 
populate automatically if you are in 
a folder already).  
 

Note: SharePoint’s filtering and view  
options make folders unnecessary in  
many cases.  
 

 Network folder file names are limited 
to 250 characters including the 
entire file path, so names should be 
concise and abbreviated where 
possible. 

 Click OK to upload the file.  
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Uploading Files 
When your file has uploaded, 
the document properties 
window will appear.  
The Name field is the file name 
of the uploaded file. 
If there is metadata in the file, it 
will populate the Title field.  
Enter any other information 
that has been set up in the 
appropriate areas and click 
OK.  
Your screen will reload and you 
will see the file in the library.  
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Uploading Files 
Note: 
Some fields, like the Assigned To field, can be created as lookup fields. 
Type the name as last name, first name and hit enter. If there are any 
spelling errors, it will not save. Click the book icon to search for names. 
Select the appropriate name from the list and click OK. 
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Questions 
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UPDATING LIST/LIBRARY 
COLUMNS  



Updating List/Library Columns 
When you update the properties of a document or folder, you will be 
prompted to check out the item. There are two methods to do so.  
 
Method 1 
 
 Check the box in front of the document. 
 Click Edit Properties on the Library Tools > Documents ribbon. 
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Updating List/Library Columns 
When you update the properties of a document or folder, you will be 
prompted to check out the item. There are two methods to do so.  
 
Method 2 
 
 Click the dropdown arrow next to the file name. 
 Click Edit Properties in the drop down menu. 
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Updating List/Library Columns 
From this screen you 
can update all the 
properties of the 
document. Make the 
necessary updates and 
click Save.  
 
This does not check in 
the file. Until the file is 
checked in, updates 
will not be visible to 
anyone else.  
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Questions 

Back to 
Contents 



UPDATING FILES 



Updating Files 
 You must use the Internet Explorer browser to utilize SharePoint 

pages. Firefox and Chrome are not compatible with SharePoint 
functions. If you encounter anything strange, especially forced 
downloads of files when you attempt to open them, check your 
browser first. 

 SharePoint will time out after 30 minutes of inactivity. Best practice is 
to save your work often, just as you would with offline files. If you 
have a document open and need to leave your desk for any reason, 
save the file first. This will ensure all your work is saved and none of 
your changes are lost.  

 If SharePoint is being used to maintain version control, all documents 
should be worked on SharePoint exclusively. In this case, do not 
download documents from SharePoint to work on them. All files must 
be opened, worked on, and saved in SharePoint, not on your hard 
drive. In order to maintain version control, it is imperative that only 
one copy of the file be used.  
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To open a file, click on the file name in the library you are working in (shared 
documents, team information, etc.). File names will always display as blue 
hyperlinks. The file will open in the appropriate Microsoft Office program. 

Opening Files 
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Click the file name only once. Be patient. If multiple copies open, you may 
inadvertently start working on a read-only copy and you will not be able to save 
your work. If multiple copies open, ensure the one you ultimately work on does 
not have [Read-Only] in the heading. If it does, close it and reopen the file from 
SharePoint.  



Editing Files 
 When opening a file, Microsoft files will open in read-only mode.  
 Click Edit Document in the yellow information ribbon across the top 

of the file.  
 The file will reload and you will be able to edit it normally. 
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Updating File Properties in Word 
If the file properties have values that do not correspond to the current options  in 
SharePoint (for example, if choices were updated), you will see a yellow ribbon 
prompting for changes. Click Edit Properties to display the properties panel in the 
document. 
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The values that require updating will highlight themselves in a broken red outline. Select 
from the provided options or update the information in the necessary manner to update 
the file.  



Updating File Properties in Excel 
If the file properties have values that do not correspond to the current options  in 
SharePoint (for example, if choices were updated), you will see a yellow ribbon 
prompting for changes. Click Edit Properties to display the properties panel in the 
document. 
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The values that require updating will highlight themselves in a broken red outline. Select 
from the provided options or update the information in the necessary manner to update 
the file.  



Questions 
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Updating Files 
 Once you open a file for editing, you can make changes to it as you 

normally would. There are no differences between updating the 
content of a SharePoint file and an offline file.  

 Track Changes and SharePoint 
– If Track Changes are on, as is standard with our files, you will not see 

other users’ updates in real time. You will still see notifications on the 
bottom of your screen indicating that there is new information available.  

 Some file types, such as Excel, cannot be opened in the web view if 
certain features are enabled.  
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Saving Files 
Update the file as needed in SharePoint. When you are ready to save, 
click the save icon, use Crtl + S on the keyboard, or go to the file 
menu and click Save. The file will be updated on SharePoint and 
anyone who opens it will see the most recent versions of the file.   

Server copies of the file will 
always have a green arrow 
around the save icon. Always 
save to the server.  
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Saving Files 
When you save a Microsoft file, you will see a status bar in the lower right corner of 
the document. It is easy to miss if you aren’t looking for it.  
PDF files do not have this status bar. If it was opened from SharePoint, it will save 
to the server.  

When working with larger files or at times when the server is slow, a popup window 
will appear indicating the file is updating. Be patient and wait for it to complete. 
Some files become very large when many images are added. The traffic on the 
network, the file size, and the power of our machines all impact the time it takes to 
save files. The file will upload and save to the library as intended.  
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Questions 
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Co-Authoring 
SharePoint offers a feature called co-authoring. This allows multiple 
users to work on the same file simultaneously.  
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Pros 
 Faster 
 Real-time updates 
 Collaborative work 

environment 
 
 

Cons 
 No real-time updates if using 

Track Changes 
 Refreshing to see changes 

 



Co-Authoring 
If there are changes made to the file by another user, you will be 
alerted. The updated areas will be bracketed and refresh arrows will be 
around the updated text, indicating a refresh is needed. 
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Co-Authoring 
If you use the 
file menu to 
save, you will 
see a 
notification of 
updates in the 
file menu as 
well. 
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Co-Authoring 
After you save to refresh the file, the updated areas will be highlighted 
for you to review. 
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Questions 
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Checking Out Files 
If it is absolutely necessary to be the only person with access to a file, 
you can check out  a file for editing. This should only be done when 
files are in the formatting and editing stage or a situation requires it. 
Otherwise, this should be avoided.  
When a file is checked out, other group members cannot make 
updates or see updates until it is checked in by the person working on 
it. If that person is out or for any reason doesn’t have access to 
SharePoint and the file is needed, it can be force checked in, but all 
changes made will be lost. There is no way to retrieve this 
information. 
Unless the version cannot change (as in the formatting and editing 
stage), there are very few practical reasons for files to be checked out.  
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Checking Out Files 
You can check out files manually or in the file. To check out a file manually: 

– Check the checkbox in front of the file row. You can select multiple files to 
check out simultaneously. 

– On the top ribbon under Library Tools, select Check Out. 
– Click OK on the pop-up window. 
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Checking Out Files 
 PDF files will prompt you for check out with a dialogue box.  
 Click Check Out & Open if you want to make any changes, including 

comments, to the file. 
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Checking Out Files 
You can also click the dropdown arrow to the right of the file name 
select Check Out.  
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Checking Out Files 
The file will not open automatically. You must still click on the file name 
to open the document. The library will update to display who has the file 
checked out.  
Checked out files will always have a green downward-facing arrow to 
indicate that status. 
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Checking In Files 
 Checking in a file can be done by closing the file. Using the X in the upper right corner or by going 

to File > Exit menu will prompt a dialog box to check in the file.  
 You do not have to check in a file until you are done with your work. Saving the file will save your 

work, but it will not be visible to others until you check in the document.  
 Click Yes to check in the file.  
 A second dialog will pop and prompt you for the version you want to save and a comment box.  
 If you want others to be able to see your changes, but continue working without others editing a file, 

check the box in front of “Keep the document checked out after checking in this version.” 
 Click OK to save.  
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Checking In Files 
A pop-up will appear to enter comments about the changes made. 
Make sure the first question remains defaulted to “No” and click OK. 
The page will refresh and the file will be updated in the library.  
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Checking In Files 
To check in a document manually, click the checkbox in front of it and 
click Check In from the Library tools ribbon.  
If you checked out the file in error and have no changes to make, you 
can also click Discard Check Out.  
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Checking In Files 
You can also click the dropdown arrow to the right of the file name 
select Check In or Discard Check Out. Checking in the file this way 
will prompt the same pop up for version and comments. 
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Questions 

Back to 
Contents 



VIEWING PRIOR 
VERSIONS OF FILES 



Viewing Prior Versions of Files 
You  view the version history 
of a file in SharePoint. Click 
the dropdown menu next to 
any file and select Version 
History.  
 
This will show you the 
version, the date and time it 
was modified, who modified 
it, and the size of the file 
along with the file properties.  
 
This will not show changes 
to the file.  

Microsoft provides instructions for viewing prior versions here. 
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https://support.office.com/en-us/article/view-the-version-history-of-an-item-or-file-in-a-list-or-library-53262060-5092-424d-a50b-c798b0ec32b1ID0EAAGAAA=2010.


Viewing Prior Versions of Files 
You can view 
previous 
versions of a file 
in Word, Excel, 
or PowerPoint 
without checking 
out the file.  
To view a 
previous version, 
open the file and 
go to the File  
menu. 
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Viewing Prior Versions of Files 
Go to Versions 
and Check Out.  
Click on any 
version to open 
a read-only 
copy of that 
version.  
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Viewing Prior Versions of Files 
There is a drop down menu under 
Manage Versions. Word, Excel, and 
PowerPoint will allow you to refresh the 
version list, check out the file, and recover 
unsaved files from this list.  
Word will also allow you to compare 
versions in a unique window.   
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Word 

Excel PowerPoint 



Viewing Prior Versions of Files 
The previous version will open in a separate file. For Word, you will 
have the option to compare to the most recent version or restore the 
previous version. For Excel and PowerPoint, you will have the option to 
restore the previous version as the most current. 
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Viewing Prior Versions of Files 
Comparing the file in Word will open a window highlighting the changes. 
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Viewing Prior Versions of Files 
If you attempt to restore the file without checking it out, you will receive 
an error message.  
 
Files generally will not need to be restored.  
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Viewing Prior Versions of Files 
You can view 
prior versions of 
a file in Word 
without checking 
out the file.  
To view a prior 
version, open the 
Excel file and go 
to the File  menu 
and go to 
Versions and 
Check Out. 
Prior versions 
can be viewed 
and restored, but 
Excel does not 
offer a compare 
function.  
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Questions 
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ADDING AND WORKING 
WITH FOLDERS 



Adding and Working with Folders 
You can add folders to any SharePoint library to organize files. To add a 
folder, go to the library you want to add a folder to. Under the Library 
Tools > Documents menu, click New Folder.  

Add the name of 
the folder in the 
Name field and 
click Save.  
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Adding and Working with Folders 
To add new documents to the folder, click the name of the folder 
under the Name column in the library. The list will reload to display 
files under that folder or an empty folder, if no files have been added.  
Click Add a document and follow the normal upload procedure to 
upload files directly to the desired folder.  
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Windows Explorer View 
To add existing files to the folder, go to the Library Tools > Library 
menu and click Open with Explorer in the ribbon.  
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Windows Explorer View 
The first time you open this each day, you will receive a login screen. 
Use your Windows/McAfee login information.  

– Do not use your PIV information.  
– Do not click “Remember my credentials” 
– If you get an error message, you need to delete the temporary files from 

Internet Explorer, follow the steps in Deleting Temporary Internet Files. 
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Windows Explorer View 
A typical folder window will open on your desktop. This functions like 
any other Windows folder.  
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Deleting Temporary Internet Files 
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If you cannot open the Windows Explorer view from SharePoint at 
any time or receive an error message stating the client doesn’t 
support opening the list with Windows Explorer, these steps must be 
taken. 



Deleting Temporary Internet Files 
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 Open Internet Explorer and go to Tools > Internet options.  
 You can also access the gear in the upper right corner and select 

Internet options. 



Deleting Temporary Internet Files 
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 Click Settings. 



Deleting Temporary Internet Files 
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 Click Temporary Internet Files > View Files. 



Deleting Temporary Internet Files 
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 In the folder that opens, select all files and delete them. 



Deleting Temporary Internet Files 
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 Click OK to close the two open system windows. You should now 
be able to open the Windows Explorer view in SharePoint.  



Questions 
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ALERTS 



Alerts 
Alerts let you know when a document, list, or library is updated based 
on criteria you set. 
To set an alert on a list or library, navigate to the list or library. Under 
Library Tools > List (Library) click the dropdown menu under Alert 
Me and select Set alert on this list (library).  
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Alerts 
Select the criteria for 
the alert and click OK. 
 
Libraries and lists will 
have different options.   
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Alerts 
To delete or update an alert on a list or library, navigate to the list or 
library. Under Library Tools > List (Library) click the dropdown menu 
under Alert Me and select Manage My Alerts.  
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Alerts 
Click the alert name to modify it. To delete an alert, click the checkbox 
and click Delete Selected Alert.  
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Questions 
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HELP AND INFORMATION 



Help and Information 
 The SharePoint How-To site has a great deal of information available 

for training, knowledge, and instruction.  
 The FAQ page has many common questions answered. 
 If there are network issues, check your email for an Employee News 

or LM Information Management message.  
 If you want to have a more intensive, self-guided explanation of 

SharePoint, I recommend the following beginner-level Lynda.com 
presentations. Lynda.com is free to use with a Mesa County  
library card.   

–  SharePoint 2010 Essential Training 
– Learning SharePoint 2010 
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https://projects.lm.doe.gov/SharePointHowTo/SitePages/Home.aspx
https://projects.lm.doe.gov/SharePointHowTo/SitePages/SharePoint FAQs.aspx
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